Home Forums Porto Template Google Maps

This topic contains 13 replies, has 2 voices, and was last updated by  mbv 1 week, 2 days ago. This post has been viewed 89 times

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #10026801

    mbv
    Participant

    Trying to get an API key for Google Maps but they are trying to bill me? Is there another option?


    #10026811

    Support2
    Keymaster

    Hello,

    Google is changing the Google Maps usage method. Now it’s required you add your billing data to use the Google Maps. You can read more about that here:
    https://cloud.google.com/maps-platform/pricing/

    and here is an article with more explanation about that:
    https://venturebeat.com/2018/05/02/google-maps-platform-arrives-with-pay-as-you-go-billing-free-support-and-cloud-requirement-starting-june-11/

    Basically you will receive an credit of $200 each month to use the google services for “free”, but for it you need add your billing information.

    Kind Regards,

    Rodrigo.


    • This reply was modified 1 week, 4 days ago by  Support2.
    • This reply was modified 1 week, 4 days ago by  Support2.
    #10026820

    mbv
    Participant

    Thanks guys! Great to hear.

    We added the billing and activated the api key which we added to the site http://www.rainmansraceway.com/

    Still getting the error though. Did we miss something in the code?


    #10026822

    Support2
    Keymaster

    Hello,

    Great!
    probably now the issue is the duplicated google maps script on the page. Please remove the script showed on image below:

    Please, try that and let me know if you need further assistance.

    Kind Regards,

    Rodrigo.


    #10026824

    mbv
    Participant

    Brilliant! That fixed it.


    #10026828

    mbv
    Participant

    Oddly the map stopped working and now we get this error:
    Oops! Something went wrong.
    This page didn’t load Google Maps correctly. See the JavaScript console for technical details.


    #10026829

    Support2
    Keymaster

    Hello :),

    Please, can you check again ?
    Inspecting your website now, the maps it’s working.

    Kind regards,

    Rodrigo.


    #10026833

    mbv
    Participant

    We have checked with several users on different machines and we are all seeing the attached. screenshot map js error


    #10026839

    Support2
    Keymaster

    Hello,

    Sorry but we still couldn’t reproduce the issue here.
    We checked in several machines and it’s loading/showing the map.
    We also tested using proxy and worked. You can do the test accessing this website https://hide.me/en/proxy and enter the URL of your website.

    You are testing the website online, not locally, right ?
    Please take a screenshot of your browser console and share with us.

    Kind Regards,

    Rodrigo.


    #10026842

    mbv
    Participant

    It is very bizarre. It works for a lil while then stops working. We are testing online, yes.

    Screen shot of browser console


    #10026845

    Support2
    Keymaster

    Hello,

    According the error on console this is the reason:

    The current URL loading the Maps JavaScript API has not been added to the list of allowed referrers. Please check the referrer settings of your API key on the Google Cloud Platform Console.

    Try the following:
    1) Access https://console.developers.google.com/project/_/apiui/credential?_ga=2.155259391.597230068.1531133979-1915402689.1531133929

    2) Select your project

    3) Click to edit the API Key

    4) Check the section “App Restrictions”. Probably it’s checked the second option “HTTP Referrers”, add the URL of your website here or just select the “none” option.

    Please, try that and let me know if you need further assistance.

    Kind Regards,

    Rodrigo.


    #10026848

    mbv
    Participant

    Thanks! Got it working. Also we moved the domain to http://www.rainmanshobby.com

    Need help with one last this and this project is done. We added a custom Floating PayPal view cart button to the site. You helped us with this on a past project. We added the code and updated the custom.css but the Image does not float and is just static on the footer of the site. Perhaps we missed something?


    #10026850

    Support2
    Keymaster

    Hello,

    The issue is you are not closing the “brace” of media queries, so the code of cart it’s inside a media querie.
    Check all media queries of your “custom.css” file and make sure you correctly close the media queries. For example:

    @media(max-width: 767px) {
    // code here
    }

    Kind Regards,

    Rodrigo.


    #10026851

    mbv
    Participant

    Oops. Missed that. Thank you! I owe you a Coke (:


Viewing 14 posts - 1 through 14 (of 14 total)