Home Forums Porto Template Nanoscroller error

This topic contains 3 replies, has 2 voices, and was last updated by  Support2 3 weeks, 3 days ago. This post has been viewed 83 times

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #10030514

    pellesoft
    Participant

    Hi, something new has happened and i cannot figure out what causing this. On the index.html-page there is a sentence under the image “Ellevio … omfattande m√§tarbyte med start 2020”. This has been working all time, but now it has stopped and i can see an error at javascript (Uncaught TypeError: this.sidebars.left.$nano.nanoScroller is not a function).

    I cannot figure out what i have changed and what is causing this error. Is it possible that you can see it?

    https://ellevio.pellesoft.se/kund/index.html

    Best regards and thanks in advance
    Pelle


    #10030522

    Support2
    Keymaster

    Hello,

    It’s missing include on the page the JS script of the Nano Scoller:

    <script src="vendor/nanoscroller/jquery.nanoscroller.min.js"></script>

    * Put this on footer of document.

    Please, try that and let us know if you need further assistance.

    Kind Regards,

    Rodrigo.


    #10030545

    pellesoft
    Participant

    Hi Rodrigo, thanks but there is no difference to make it run when adding this, but the javascript error dissapeared.
    Have i done something wrong in the html perhaps?

    I had an old page, there it works with the rolling information, see https://ellevio.pellesoft.se/kund/index-org.html

    https://ellevio.pellesoft.se/kund/index.html

    Regards
    Pelle


    #10030548

    Support2
    Keymaster

    Hello Pelle,

    Now the issue is the way that you are integrating the Porto Admin with Porto HTML. At really we don’t recommend the way are doing (including theme.js and theme.init.js from Porto Admin on the page).

    The best way to integrate is here:

    * This will solve the issue with Word Rotator.

    OBS:
    In case of you want to maintain your method and not the mentioned above: The issue is that the code of Porto Admin Word Rotator is conflicting with Porto HTML Word Rotator. In that case my suggestion is remove the Word Rotator code of admin/theme.js (line 4050 until 4155).

    We hope this helps.

    Kind Regards,

    Rodrigo.


Viewing 4 posts - 1 through 4 (of 4 total)