Home Forums Porto Template Simple-php-captcha sometimes not showing image

This topic contains 5 replies, has 2 voices, and was last updated by  Support2 1 month ago. This post has been viewed 93 times

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #10027401

    neumicha
    Participant

    Hi,
    not sure if I am right here. The template also includes the simple-php-captcha tool.

    After building my website I noticed that the captcha-image works in about 9 of 10 times. But sometimes the image can not be loaded.

    I pasted a code snippet of a working and a not working $_SESSION on pastebin:
    https://pastebin.com/EWMRpPzd

    Anybody knows what the problem is? Thought about one background-url being wrong. But copied them all by hand again. They all exist.


    #10027406

    Support2
    Keymaster

    Hello,

    We made a test with your code here and probably the issue is the fonts option of “Simple PHP Captcha”.
    Check if you have uploaded the folder “simple-php-captcha/fonts” to the server.

    Please, try that and let us know if you need further assistance.

    Kind Regards,

    Rodrigo.


    #10027408

    neumicha
    Participant

    Thanks for your quick answer. The “fonts” folder is there. And the font “times_new_yorker.ttf” is also there. In the options I only set that one font and as already mentioned, the code works about 9 out of 10 times – so I dont think it is an issue with the fonts-folder or font-file. The error would persist.

    Some others also seem to have that problem. Their advises did not help (if it really is the same problem):
    https://github.com/yasirmturk/simple-php-captcha/issues/21 (just scroll down a bit)

    The $_SESSION[‘captcha’][‘image_src’] always looks good. Unfortunatelly cant really check it because of that timestamp/parameter how the later image is generated.

    Best Regards


    #10027411

    Support2
    Keymaster

    Hello,

    Please do the following test:
    – Don’t use multiple backgrounds. Just take off the backgrounds option.

    An alternative is use the Google reCaptcha. Here is a tutorial explaining how to integrate:

    Kind Regards,

    Rodrigo.


    #10027413

    neumicha
    Participant

    Dear Rodrigo,

    using only one background did not solve the problem. But I figured out a solution:
    I set max_font_size from 32 to 25 and the captcha now always works fine. Perhaps some letters are generated outside of the captcha with a font-size too high.

    For the moment I will use this as a solution. Time will show if it is secure enough or if I have to rely on the Google Recaptcha thing. If you have experience about this, it would be glad when you share them.

    Thanks.
    Best Regards,
    Michael


    #10027416

    Support2
    Keymaster

    Hello Michael,

    Great that you figured this out and thanks for share the solution with us.

    If you need further assistance, feel free to contact us.

    Kind Regards,

    Rodrigo.


Viewing 6 posts - 1 through 6 (of 6 total)