Mailto and Contact Form

Home Forums Porto Admin – Responsive HTML5 Template Mailto and Contact Form

  • This topic has 10 replies, 2 voices, and was last updated 1 year ago by AndeeR. This post has been viewed 680 times
Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #10043309
    AndeeR
    Participant

    Neither my mailto links nor my contact form are working. For the mailto I just get a blank webpage, and for the contact form I get an error message.

    This is my mailto code:

    <a href="mailto:[email protected]" target="_blank" title="Mail Us" rel="noopener noreferrer">
    <span class="custom-call-to-action-2 text-color-light text-2 custom-opacity-font">											Email									<span class="info text-5">										info@lionsgroup<br>investigations.com									</span>								</span>
    </a>

    And my contact form code is below. But I’m sure the problem is that I don’t know where to set the email address to send to for the form.

    <form class="contact-form custom-contact-form-style-1 form-errors-light" action="php/contact-form.php" method="POST">
    									<div class="contact-form-success alert alert-success d-none mt-4">
    										<strong>Success!</strong> Your message has been sent to us.
    									</div>
    									<div class="contact-form-error alert alert-danger d-none mt-4">
    										<strong>Error!</strong> There was an error sending your message.
    										<span class="mail-error-message text-1 d-block"></span>
    									</div>
    									<input type="hidden" name="subject" value="Contact Message Received" />
    									<div class="row">
    										<div class="form-group col">
    											<div class="custom-input-box">
    												<i class="icon-user icons text-color-primary"></i>
    												<input type="text" value="" data-msg-required="Please enter your name." maxlength="100" class="form-control" name="name" placeholder="Name*" required>
    											</div>
    										</div>
    									</div>
    									<div class="row">
    										<div class="form-group col">
    											<div class="custom-input-box">
    												<i class="icon-envelope icons text-color-primary"></i>
    												<input type="email" value="" data-msg-required="Please enter your email address." data-msg-email="Please enter a valid email address." maxlength="100" class="form-control" name="email" placeholder="Email*" required>
    											</div>
    										</div>
    									</div>
    									<div class="row">
    										<div class="form-group col">
    											<div class="custom-input-box">
    												<i class="icon-bubble icons text-color-primary"></i>
    												<textarea maxlength="5000" data-msg-required="Please enter your message." rows="10" class="form-control" name="message" placeholder="Message*" required></textarea>
    											</div>
    										</div>
    									</div>
    									<p>We respond within 12 hours or less.</p>
                                        <div class="row">
    										<div class="form-group col">
    											<input type="submit" value="Submit Now" class="btn btn-outline custom-border-width btn-primary custom-border-radius font-weight-semibold text-uppercase" data-loading-text="Loading...">
    										</div>
    									</div>
    								</form>

    • This topic was modified 1 year ago by Support.
    #10043315
    Support
    Keymaster

    Hi,

    1) I tested the mailto on your site and it worked well except for the one in the red bar in the footer, in that one you are using “mail:” insted of “mailto:”. You also don’t need to set “target=” – In the one at the header you need to set z-index to 10. – looking-for custom-position-1 custom-md-border-top z-index-10

    2) Please check this topic: https://www.okler.net/forums/topic/important-contact-form-is-not-working/ – Try to configure the email and if it doesn’t work check the server logs.

    Kind Regards.


    #10043321
    AndeeR
    Participant
    This reply has been marked as private.
    #10043324
    Support
    Keymaster
    This reply has been marked as private.
    #10043331
    AndeeR
    Participant

    I tried this in a completely new contact-form.php file, and still getting the error message.


    #10043332
    Support
    Keymaster

    Hi, if possible send us FTP access to your site (as a private reply), but I’m sure it’s server related issue.

    Kind Regards.


    #10043333
    AndeeR
    Participant
    This reply has been marked as private.
    #10043334
    Support
    Keymaster
    This reply has been marked as private.
    #10043335
    AndeeR
    Participant
    This reply has been marked as private.
    #10043336
    Support
    Keymaster
    This reply has been marked as private.
    #10043337
    AndeeR
    Participant
    This reply has been marked as private.
Viewing 11 posts - 1 through 11 (of 11 total)

This topic is marked as "RESOLVED" and can not rceive new replies.